<!DOCTYPE html>
<!--[if lt IE 9 ]>    <html class="lt-ie9 no-js"  lang="en" dir="ltr"> <![endif]-->
<!--[if gte IE 9]><!--> <html class="no-js"  lang="en" dir="ltr"  prefix="fb: http://www.facebook.com/2008/fbml
 content: http://purl.org/rss/1.0/modules/content/
 dc: http://purl.org/dc/terms/
 foaf: http://xmlns.com/foaf/0.1/
 og: http://ogp.me/ns#
 rdfs: http://www.w3.org/2000/01/rdf-schema#
 sioc: http://rdfs.org/sioc/ns#
 sioct: http://rdfs.org/sioc/types#
 skos: http://www.w3.org/2004/02/skos/core#
 xsd: http://www.w3.org/2001/XMLSchema#
"> <!--<![endif]-->
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://www.portchesterny.com/sites/all/themes/custom/sites/portchesterny/vts_portchesterny/favicon.ico" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" /><script type="text/javascript">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</script>
<meta name="description" content="NEW YORK STATE’S METRICS REVIEWHow does Westchester County measure up?" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://www.portchesterny.com/home/news/westchester-county-executive-latimer-invites-town-and-village-leaders-and-restaurant-and" />
<link rel="shortlink" href="https://www.portchesterny.com/node/49663" />
    <title>Westchester County Executive Latimer invites Town and Village leaders, and restaurant and shop owners in your municipality, to review New York State’s metrics and Westchester’s progress on reopening. | Port Chester NY</title>

    <style>
@import url("https://www.portchesterny.com/modules/system/system.base.css?qp8efs");
@import url("https://www.portchesterny.com/modules/system/system.menus.css?qp8efs");
@import url("https://www.portchesterny.com/modules/system/system.messages.css?qp8efs");
@import url("https://www.portchesterny.com/modules/system/system.theme.css?qp8efs");
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/modules/contrib/calendar/css/calendar_multiday.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/calendar_tooltips/calendar_tooltips.css?qp8efs");
@import url("https://www.portchesterny.com/modules/comment/comment.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/date/date_repeat_field/date_repeat_field.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/fences/field.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/fitvids/fitvids.css?qp8efs");
@import url("https://www.portchesterny.com/modules/node/node.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/picture/picture_wysiwyg.css?qp8efs");
@import url("https://www.portchesterny.com/modules/search/search.css?qp8efs");
@import url("https://www.portchesterny.com/modules/user/user.css?qp8efs");
</style>
<style media="screen">
@import url("https://www.portchesterny.com/sites/all/modules/features/vts_bids/vts_bids.css?qp8efs");
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/modules/custom/vts_calendar_colors/css/vts_calendar_colors.css?qp8efs");
</style>
<style media="screen">
@import url("https://www.portchesterny.com/sites/all/modules/features/vts_content_types/vts_content_types.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/features/vts_rules/vts_rules.css?qp8efs");
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/modules/contrib/date_repeat_entity/date_repeat_entity.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/views/css/views.css?qp8efs");
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/modules/contrib/colorbox/styles/default/colorbox_style.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/ctools/css/ctools.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/panels/css/panels.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/content_type_extras/css/content_type_extras.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/print/print_ui/css/print_ui.theme.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/modules/contrib/menu_minipanels/css/menu_minipanels.css?qp8efs");
</style>
<style>.webform-component-file .form-submit{display:none;!important}
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/modules/contrib/hide_submit/css/hide_submit.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/libraries/superfish/css/superfish.css?qp8efs");
@import url("https://www.portchesterny.com/sites/all/libraries/superfish/css/superfish-smallscreen.css?qp8efs");
</style>
<style>
@import url("https://www.portchesterny.com/sites/all/themes/custom/sites/portchesterny/vts_portchesterny/css/style.css?qp8efs");
</style>
<style media="print">
@import url("https://www.portchesterny.com/sites/all/themes/custom/vts_aurora/css/print.css?qp8efs");
</style>
<style media="screen">.bg-container { background-image: url('https://www.portchesterny.com/sites/g/files/vyhlif1096/f/styles/mobile_background/public/backgrounds/bg.jpg?itok=vMU_zpXZ'); }</style>
<style media="screen and (min-width: 768px)">.bg-container { background-image: url('https://www.portchesterny.com/sites/g/files/vyhlif1096/f/styles/tablet_background/public/backgrounds/bg.jpg?itok=s0XoFX-K'); }</style>
<style media="screen and (min-width: 960px)">.bg-container { background-image: url('https://www.portchesterny.com/sites/g/files/vyhlif1096/f/styles/desktop_background/public/backgrounds/bg.jpg?itok=AwqSqUCD'); }</style>
<style media="screen and (min-width: 1235px)">.bg-container { background-image: url('https://www.portchesterny.com/sites/g/files/vyhlif1096/f/styles/full-size_background/public/backgrounds/bg.jpg?itok=Zdf_X2mv'); }</style>
    <script src="https://www.portchesterny.com/misc/jquery.js?v=1.4.4"></script>
<script src="https://www.portchesterny.com/misc/jquery-extend-3.4.0.js?v=1.4.4"></script>
<script src="https://www.portchesterny.com/misc/jquery-html-prefilter-3.5.0-backport.js?v=1.4.4"></script>
<script src="https://www.portchesterny.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://www.portchesterny.com/misc/drupal.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/fitvids/jquery.fitvids.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/beautytips/js/jquery.bt.min.js?v=0.9.5-rc1"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/beautytips/js/beautytips.min.js?v=7.x-2.x"></script>
<script>document.createElement( "picture" );</script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/fitvids/fitvids.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/colorbox/jquery.colorbox-min.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/colorbox/js/colorbox.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/colorbox/styles/default/colorbox_style.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?qp8efs"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-84593456-44", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");</script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/hide_submit/js/hide_submit.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/superfish/sftouchscreen.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/superfish/sfsmallscreen.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/superfish/supposition.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/libraries/superfish/superfish.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/superfish/superfish.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/themes/custom/vts_aurora/js/text_filtering.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/themes/custom/vts_aurora/js/accordion_menu.js?qp8efs"></script>
<script src="https://www.portchesterny.com/sites/all/themes/custom/vts_aurora/js/vts_misc.js?qp8efs"></script>
<script>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</script>
  </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-49663 node-type-news-article og-context og-context-node og-context-node-1  default-masthead vts-portchesterny" >
    <div id="skip-link">
      <a href="#main" class="element-invisible element-focusable" role="link">Skip to main content</a>
    </div>
          <div class="bg-container"></div>
<div id="page" class="vts-site-template vts-masthead-full-bg vts-menu-full-bg vts-titlebar-full-bg vts-footer-full-bg panels-page no-sidebars">
      <header id="header" role="banner" class="region">
      <div class="container clearfix">
        <div class="vts-inner-6-6" id="mini-panel-site_heading_custom">
  
      <div class="inner-two-column-50-50">
      <div class="inner-two-column-50-50__first">
        <div id="logo"><a href="https://www.portchesterny.com/"><img typeof="foaf:Image" src="https://www.portchesterny.com/sites/all/themes/custom/sites/portchesterny/vts_portchesterny/logo.png" alt="Port Chester NY" /></a></div>      </div>
      <div class="inner-two-column-50-50__second">
        <div id="home-button"><a href="https://www.portchesterny.com/"><i class="icon"></i><span class="screen-reader-text">Home</span></a></div>
<form action="/advanced-search" method="get" id="views-exposed-form-search-advanced-site-search" accept-charset="UTF-8"><div><div class="views-exposed-form">
  <div class="views-exposed-widgets clearfix">
          <div id="edit-keywords-wrapper" class="views-exposed-widget views-widget-filter-search_api_views_fulltext">
                  <label for="edit-keywords">
            Keywords          </label>
                        <div class="views-widget">
          <div class="form-item form-type-textfield form-item-keywords">
 <input placeholder="Search" type="text" id="edit-keywords" name="keywords" value="" size="30" maxlength="128" class="form-text" />
</div>
        </div>
              </div>
                    <div class="views-exposed-widget views-submit-button">
      <input type="submit" id="edit-submit-search-advanced" name="" value="Search" class="form-submit" />    </div>
      </div>
</div>
</div></form>
<style type="text/css">
<!--/*--><![CDATA[/* ><!--*/
.header--social-icons-custom a {
     color: white;
}
.header--social-icons-custom a:hover {
     color: #70b9e7;
     text-decoration: none;
}
@media (min-width:768px) {
     .header--social-icons-custom {
          float: right;
          margin-left: 18px;
          margin-top: 17px;
     }
}

/*--><!]]>*/
</style><div class="header--social-icons-custom"><a class="fa fa-facebook-square fa-2x" href="https://www.facebook.com/portchesterny" target="_blank"><span class="screen-reader-text">Facebook</span></a>   <a class="fa fa-twitter-square fa-2x" href="https://www.twitter.com/portchesterny" target="_blank"><span class="screen-reader-text">Twitter</span></a>   <a class="fa fa-youtube-square fa-2x" href="https://www.youtube.com/channel/UCDt9e3CElA38JdnekjPMBTQ/featured" target="_blank"><span class="screen-reader-text">YouTube</span></a></div>
<meta data-name="google-translate-customization" property="google-translate-customization" content="53ca2a3b604b9f1b-65b8ec81c0221577-gd881e16014cef371-d" /><div id="google_translate_element"></div><script>function waitForTranslateToDisplay(selector, time) { if(document.querySelector(selector)!=null) { var translate = document.getElementsByClassName("goog-te-combo")[0]; translate.setAttribute("aria-label", "Select language for translation");} else {setTimeout(function() { waitForTranslateToDisplay(selector, time);}, time);}}</script><script>function googleTranslateElementInit() {new google.translate.TranslateElement({pageLanguage: "en"}, "google_translate_element"); waitForTranslateToDisplay(".goog-te-combo", 500);}</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>      </div>
    </div>
    </div>
      </div>
    </header>
  
      <nav id="navigation" role="navigation" class="region">
      <div class="container clearfix">
        <ul  id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-none sf-total-items-6 sf-parent-items-1 sf-single-items-5"><li id="menu-1037-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/about-us" class="sf-depth-1 menuparent">About Us</a><ul><li id="menu-3833-1" class="firstandlast odd sf-item-1 sf-depth-2 sf-no-children"><a href="/about-us/pages/our-history" target="_self" class="sf-depth-2">Our History</a></li></ul></li><li id="menu-848-1" class="middle even sf-item-2 sf-depth-1 sf-no-children"><a href="/where" class="sf-depth-1">How Do I?</a></li><li id="menu-1303-1" class="middle odd sf-item-3 sf-depth-1 sf-no-children"><a href="/departments" class="sf-depth-1 menu-minipanel menu-minipanel-0 menuparent">Departments</a><ul class="menu-minipanel-panel menu-minipanel-mega-menu-departments">
  <li class="first odd last">
    <div class="vts-inner-4-4-4" id="mini-panel-mega_menu_departments">
  
      <div class="inner-three-column">
      <div class="inner-three-column__first">
                  <section class="panel-pane pane-block pane-menu-block-1" >
  <div class="pane-inner clearfix">
    
              <h2 class="pane-title">
        Departments      </h2>
        
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-1 menu-name-main-menu parent-mlid-1243 menu-level-1">
  <ul class="menu"><li class="first leaf has-children menu-mlid-1038"><a href="/assessor-tax-office">Assessor &amp; Tax Office</a></li>
<li class="leaf has-children menu-mlid-1039"><a href="/building-department">Building Department</a></li>
<li class="leaf has-children menu-mlid-1040"><a href="/code-enforcement-department">Code Enforcement Department</a></li>
<li class="leaf has-children menu-mlid-1041"><a href="/department-public-works">Department of Public Works</a></li>
<li class="last leaf has-children menu-mlid-1042"><a href="/fire-department">Fire Department</a></li>
</ul></div>
    </div>

    
        
  </div>
</section>
              </div>
      <div class="inner-three-column__second">
                  <div class="panel-pane pane-block pane-menu-block-2" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-2 menu-name-main-menu parent-mlid-1253 menu-level-1">
  <ul class="menu"><li class="first leaf has-children menu-mlid-1043"><a href="/justice-court">Justice Court</a></li>
<li class="leaf has-children menu-mlid-1044"><a href="/mayor">Mayor</a></li>
<li class="leaf has-children menu-mlid-3213"><a href="/parks">Parks</a></li>
<li class="leaf has-children menu-mlid-1045"><a href="/planning-economic-development">Planning &amp; Development</a></li>
<li class="leaf has-children menu-mlid-1046"><a href="/police-department">Police Department</a></li>
<li class="leaf has-children menu-mlid-1047"><a href="/recreation">Recreation</a></li>
<li class="last leaf has-children menu-mlid-1048"><a href="/senior-community-center">Senior Community Center</a></li>
</ul></div>
    </div>

    
        
  </div>
</div>
              </div>
      <div class="inner-three-column__third">
                  <div class="panel-pane pane-block pane-menu-block-3 pane-padding-bottom-none" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-3 menu-name-main-menu parent-mlid-1263 menu-level-1">
  <ul class="menu"><li class="first leaf has-children menu-mlid-1049"><a href="/treasurer-office">Treasurer Office</a></li>
<li class="leaf has-children menu-mlid-1050"><a href="/village-attorney">Village Attorney</a></li>
<li class="leaf has-children menu-mlid-1034"><a href="/village-clerk">Village Clerk</a></li>
<li class="leaf menu-mlid-2853"><a href="/village-corporation-counsel">Village Corporation Counsel</a></li>
<li class="leaf has-children menu-mlid-6543"><a href="/village-engineer">Village Engineer</a></li>
<li class="leaf has-children menu-mlid-1051"><a href="/village-manager">Village Manager</a></li>
<li class="last leaf menu-mlid-6733"><a href="/youth-bureau">Youth Bureau</a></li>
</ul></div>
    </div>

    
        
  </div>
</div>

<div class="panel-pane pane-custom pane-2" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <p><a href="https://www.portchesterny.com/departments"><span class="fa fa-university"> </span>All Departments</a></p>    </div>

    
        
  </div>
</div>
              </div>
    </div>
  
  </div>
  </li>
</ul>
</li><li id="menu-1313-1" class="middle even sf-item-4 sf-depth-1 sf-no-children"><a href="/boards" class="sf-depth-1 menu-minipanel menu-minipanel-0 menuparent">Boards &amp; Committees</a><ul class="menu-minipanel-panel menu-minipanel-mega-menu-boards">
  <li class="first odd last">
    <div class="vts-inner-4-4-4" id="mini-panel-mega_menu_boards">
  
      <div class="inner-three-column">
      <div class="inner-three-column__first">
                  <section class="panel-pane pane-block pane-menu-block-4" >
  <div class="pane-inner clearfix">
    
              <h2 class="pane-title">
        Boards &amp; Committees      </h2>
        
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-4 menu-name-main-menu parent-mlid-1273 menu-level-1">
  <ul class="menu"><li class="first leaf menu-mlid-4883"><a href="/2020-census-complete-count-committee">2020 Census Complete Count Committee</a></li>
<li class="leaf has-children menu-mlid-1052"><a href="/alarm-review-board">Alarm Review Board</a></li>
<li class="leaf has-children menu-mlid-1053"><a href="/architectural-board-review">Architectural Board of Review</a></li>
<li class="leaf has-children menu-mlid-1054"><a href="/beautification-commission">Beautification Commission</a></li>
<li class="leaf has-children menu-mlid-1055"><a href="/board-trustees">Board of Trustees</a></li>
<li class="leaf menu-mlid-1056"><a href="/cdbg-municipal-representative">CDBG Municipal Representative</a></li>
<li class="last leaf has-children menu-mlid-6123"><a href="/city-status-committee">City Status Committee</a></li>
</ul></div>
    </div>

    
        
  </div>
</section>
              </div>
      <div class="inner-three-column__second">
                  <div class="panel-pane pane-block pane-menu-block-5" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-5 menu-name-main-menu parent-mlid-1283 menu-level-1">
  <ul class="menu"><li class="first leaf has-children menu-mlid-1057"><a href="/comprehensive-plan-advisory-committee">Comprehensive Plan Advisory Committee</a></li>
<li class="leaf menu-mlid-1058"><a href="/ethics-board">Ethics Board</a></li>
<li class="leaf menu-mlid-1059"><a href="/fire-advisory-board">Fire Advisory Board</a></li>
<li class="leaf menu-mlid-1060"><a href="/housing-authority">Housing Authority</a></li>
<li class="leaf has-children menu-mlid-993"><a href="/home/industrial-development-agency">Industrial Development Agency</a></li>
<li class="leaf menu-mlid-1061"><a href="/library-bt">Library B/T</a></li>
<li class="leaf has-children menu-mlid-1062"><a href="/local-development-corporation">Local Development Corporation</a></li>
<li class="last leaf has-children menu-mlid-1063"><a href="/park-commission">Park Commission</a></li>
</ul></div>
    </div>

    
        
  </div>
</div>
              </div>
      <div class="inner-three-column__third">
                  <div class="panel-pane pane-block pane-menu-block-6 pane-padding-bottom-none" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <div class="menu-block-wrapper menu-block-6 menu-name-main-menu parent-mlid-1293 menu-level-1">
  <ul class="menu"><li class="first leaf has-children menu-mlid-1064"><a href="/planning-commission">Planning Commission</a></li>
<li class="leaf menu-mlid-1065"><a href="/recreation-commission">Recreation Commission</a></li>
<li class="leaf menu-mlid-6523"><a href="http://www.portchesterny.com/port-chester-sustainability-committee">Sustainability Committee</a></li>
<li class="leaf menu-mlid-1066"><a href="/taxi-commission">Taxi Commission</a></li>
<li class="leaf menu-mlid-1067"><a href="/traffic-commission">Traffic Commission</a></li>
<li class="leaf has-children menu-mlid-1068"><a href="/waterfront-commission">Waterfront Commission</a></li>
<li class="last leaf has-children menu-mlid-1069"><a href="/zoning-board">Zoning Board</a></li>
</ul></div>
    </div>

    
        
  </div>
</div>

<div class="panel-pane pane-custom pane-3" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <p><a href="https://www.portchesterny.com/boards"><span class="fa fa-users"> </span>All Boards &amp; Committees</a></p>    </div>

    
        
  </div>
</div>
              </div>
    </div>
  
  </div>
  </li>
</ul>
</li><li id="menu-1018-1" class="middle odd sf-item-5 sf-depth-1 sf-no-children"><a href="/home/webforms/contact-us" class="sf-depth-1">Contact Us</a></li><li id="menu-1019-1" class="last even sf-item-6 sf-depth-1 sf-no-children decorative-menu-item"><a href="/home/pages/find-it-fast" class="sf-depth-1 menu-minipanel menu-minipanel-1019 menuparent">Find It Fast</a><ul class="menu-minipanel-panel menu-minipanel-find-it-fast-drop-down">
  <li class="first odd last">
    <div class="vts-3-col-no-wrap">
  
      <div class="three-column-no-wrap">
      <div class="three-column-no-wrap__first">
                  <div class="panel-pane pane-custom pane-4" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <h3>Public Works</h3><ul><li><a href="https://www.portchesterny.com/department-public-works/files/sanitation-schedule-2016-17" target="_blank">Sanitation Schedule </a></li><li>County Recycling Guidelines - <a href="https://www.portchesterny.com/department-public-works/files/county-recycling-guidelines" target="_blank">English</a> &amp; <a href="https://www.portchesterny.com/department-public-works/files/county-recycling-guidelines-spanish" target="_blank">Spanish</a></li></ul>    </div>

    
        
  </div>
</div>
              </div>
      <div class="three-column-no-wrap__second">
                  <div class="panel-pane pane-custom pane-5" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <h3>Quick Forms</h3><ul><li><a href="https://www.portchesterny.com/building-department/files/building-permit-application-package" target="_blank">Building Permit Application Package</a></li><li><a href="https://www.portchesterny.com/village-clerk/files/freedom-information-request" target="_blank">FOIL Request</a></li></ul>    </div>

    
        
  </div>
</div>
              </div>
      <div class="three-column-no-wrap__third">
                  <div class="panel-pane pane-custom pane-6" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <h3>Board of Trustees</h3><ul><li><a href="https://www.portchesterny.com/node/43/minutes">Board of Trustees Minutes</a></li><li><a href="https://www.portchesterny.com/node/43/agenda">Board of Trustees Agendas</a></li><li><a href="https://www.portchesterny.com/pc-tv">Meeting Videos </a></li></ul>    </div>

    
        
  </div>
</div>
              </div>
    </div>
  
  </div>
  </li>
</ul>
</li></ul>      </div>
    </nav>
  
      <div id="messages-help-wrapper" class="region">
      <div class="container clearfix">
        
      </div>
    </div>
  
  
  <div id="main">
    <div class="container clearfix">
      <div id="content" role="main" class="region">
        <div class="panel-pane pane-page-content" >      
            
    
          <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="panel-display clearfix vts-three-column page-no-sidebars" >

  
  <div class="clearfix panel-row">
    <div class="region region-page-content">
      <div class="region-inner clearfix">
        <div class="vts-single-column" id="mini-panel-share_print_breadcrumbs">
  <div class="panel-pane pane-block pane-print-ui-print-links pane-print-print-links" >      
            
    
          <span class="print_html"><a href="https://www.portchesterny.com/print/49663" title="Display a printer-friendly version of this page." class="print-html" rel="nofollow"><img class="print-icon" typeof="foaf:Image" src="https://www.portchesterny.com/sites/all/modules/contrib/print/icons/print_icon.png" alt="Print" title="Print" /></a></span>    
    
      </div><div class="panel-pane pane-block pane-addthis-addthis-block" >      
            
    
          <a class="addthis_button "><img src="https://s7.addthis.com/static/btn/sm-share-en.gif" alt="Share page with AddThis" />
</a>
    
    
      </div><nav class="breadcrumb" role="navigation"><h2 class="element-invisible">You are here</h2><ol><li><a href="/">Home</a></li></ol></nav></div>
<header class="panel-pane region-page-title"><h1 class="page-title">Westchester County Executive Latimer invites Town and Village leaders, and restaurant and shop owners in your municipality, to review New York State’s metrics and Westchester’s progress on reopening.</h1><div class="submitted">Posted on: May 27, 2020 - 10:26am</div></header>
<div class="panel-pane pane-node-content" >
  <div class="pane-inner clearfix">
    
            
    
    <div class="pane-content">
      <article class="node-49663 node node-news-article node-sticky clearfix" about="/home/news/westchester-county-executive-latimer-invites-town-and-village-leaders-and-restaurant-and" typeof="sioc:Item foaf:Document" role="article">
      <header>
                  <span property="dc:title" content="Westchester County Executive Latimer invites Town and Village leaders, and restaurant and shop owners in your municipality, to review New York State’s metrics and Westchester’s progress on reopening." class="rdf-meta element-hidden"></span><span property="sioc:num_replies" content="0" datatype="xsd:integer" class="rdf-meta element-hidden"></span>    </header>
      
  <div class="content">
    
  <figure class="field field-name-field-node-image field-type-image field-label-hidden">
    <img typeof="foaf:Image" src="https://www.portchesterny.com/sites/g/files/vyhlif1096/f/styles/news_image/public/news/color_port_chester_seal_2x2_20.png?itok=cs0_LOI_" alt="VPC Logo" />  </figure>

<div class="field field-name-body field-type-text-with-summary field-label-hidden">
  
      
    <p><strong>NEW YORK STATE’S METRICS REVIEW</strong></p><p><em>How does Westchester County measure up?</em></p><p>Westchester County Executive Latimer invites Town and Village leaders, and restaurant and shop owners in your municipality, to review New York State’s metrics and Westchester’s progress on reopening.</p><p><strong>THURSDAY, MAY 28</strong></p><p><strong>4 P.M.</strong></p><p><strong>VIA WEBEX</strong></p><p>County Executive Latimer will respond to questions and listen to concerns particularly on how this impacts border communities.</p><p><u>We ask that you share this with your</u><u>,</u><u>restaurateurs and shop owners who are impacted by those that have opened in Connecticut under its Phase I, but the number of participants is limited. We will take reservations on a first come first serve basis</u>.</p><p>RSVP and submit questions to me at <a href="mailto:ephh@westchestergov.com" target="_blank">ephh@westchestergov.com</a> <strong>by noon May 27</strong>.  The link will be provided once your RSVP is received.</p>
      </div>
  </div>

    
</article>
    </div>

    
        
  </div>
</div>
      </div>
    </div>

      </div>

  
</div>  </div>
</div>
    
    
      </div>      </div>

          </div>
  </div>

  
      <footer id="footer" role="contentinfo" class="region">
      <div class="container clearfix">
        <div class="panel-pane pane-block pane-vts-blocks-5" >      
            
    
          <p>Village of Port Chester, 222 Grace Church Street, Port Chester, New York 10573<br />914-939-5200  Fax: 914-937-3169 | <a href="https://www.portchesterny.com/home/webforms/contact-us">Contact Us</a> | <a href="https://www.portchesterny.com/home/pages/website-disclaimer-and-statements">Disclaimer</a><br /><a href="https://www.civicplus.com" target="_blank">Government Websites by CivicPlus ®</a></p>    
    
      </div>
<ul id="vts-user-menu"><li class="first"><a href="/user/login?current=node/49663">Login</a></li></ul>      </div>
    </footer>
  
</div>
    <script src="https://www.portchesterny.com/sites/all/modules/contrib/picture/picturefill2/picturefill.min.js?v=2.3.1"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/picture/picture.min.js?v=7.77"></script>
<script src="https://www.portchesterny.com/sites/all/modules/contrib/addthis/addthis.js?qp8efs"></script>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"NRJS-acd47eab6e866cba245","applicationID":"501552039","transactionName":"MVVUZEdVXhUDVRULVggfd1NBXV8ITUYABVw5XVdeVFNVFD1YDgZcOUZfVUJrQAcFUw==","queueTime":0,"applicationTime":520,"atts":"HRJXEg9PTRs=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>
